Please login or register. September 20, 2018, 07:54:30 PM

Author Topic: Subtitles on OpenDCP  (Read 14986 times)

Herve

  • New Member
  • **
  • Posts: 1
    • View Profile
Subtitles on OpenDCP
« on: June 05, 2014, 12:58:26 AM »
Hello ! I'am a newbee about DCP structure and XML. I tried to insert a subtitle file through the site "http://www.michaelcinquin.com/tools/DCP/DCP_subtitling". I obtain the files that seem ok but when i try to manage them in OpenDCP i allway got a failure. with any explanation.
If any of you understand how i can get rid of these messages and obtain the right mxf file for subtitling, it would help me a lot.

Lars_G

  • New Member
  • **
  • Posts: 16
    • View Profile
Re: Subtitles on OpenDCP
« Reply #1 on: June 18, 2014, 02:27:14 PM »
A couple details about this.

A) OpenDCP uses/takes SMPTE type xml files fro subtitles to convert/wrap to MXF, afaik smpte xml has a different (not sure how widely, just yet, implementing Interop Plain XMl files+font on opendcp xml generation is something I want to do someday soon) schema to Interop, so make sure the schema you're using is correct.

B) When using subtitles on MXF for SMPTE, the duration of the subs needs to be the same as the audio and video assets, so you normally need to add empty (textless) subtitles on the first frame and a similar empty one that ends on the last frame, you can't use subtitles that start after the first frame of the content.

brunoMG

  • New Member
  • **
  • Posts: 10
    • View Profile
Re: Subtitles on OpenDCP
« Reply #2 on: July 10, 2014, 09:11:45 AM »
I think there is a bug in michailecinquin script that I encountered, that could be relevant to this case. Two bugs actually.

So you build DCP with OpenDCP and include only video + audio.

Then for adding subtitle:

First, in this tool: http://www.michaelcinquin.com/tools/DCP/DCP_subtitling  - You have to chose Interpop as Lars suggested. I didn't suceed to build SMPTE subtitles that work via this tool. That's first bug I think.

Secondly, in this tool http://www.michaelcinquin.com/tools/DCP/versioning -You upload all requested XML files from DCP without subtitles (one you generated with only vid+audio), font file, and connect it all.
-> two things you should watch out :
1. You can't use font larger than 640KB because it could cause problems! - However there is a tool, as Wolfgang suggested, at the end of this page : https://github.com/wolfgangw/digital_cinema_tools/wiki/Frequently-asked-questions
It's called Cinema Font Compressor and what you do is input xml subtitle from DCP_Subtitling tool (michaelcinquin.com) and font (Arial is larger than 640 for egzample) and then this tool get's rid of all characters that are not used in your subtitle file and you get a light version of your font.
2. Keep original cpl : no -> That's second bug. When you keep it on yes, you get 2 cpl files. When you play it with both files in EasyDCP, it works by showing you two versions, but when you delete one that doesn't have subtitles, EasyDCP Player shoots some errors. You don't want to give out 2 cpl files risking that one without subtitles could be played.


So this is working solution for Interpop subtitles, which as I understood, means that you can build 24f and 48f subtitled DCP without a problem. If you want to have 25,30,50 or 60fps DCP, you will have to use SMPTE standard. I still didn't figure this out, even with OpenDCP, so I can't help you there for now.





hdvprojection

  • Full Member
  • ****
  • Posts: 216
    • View Profile
Re: Subtitles on OpenDCP
« Reply #3 on: August 16, 2018, 04:08:47 PM »
I keep getting "No timeline loaded" from the Build Subtitling File page. It looks like it's refusing to upload the SRT file I'm selecting.

Edit: Never mind... I'm an idiot.
« Last Edit: August 16, 2018, 04:22:16 PM by hdvprojection »

dcinemaforum.com

Re: Subtitles on OpenDCP
« Reply #3 on: August 16, 2018, 04:08:47 PM »